Luar's Flash Playground:AMFPHP不兼容PHP 5.0.3
新聞(101)
觀點或評論(94)
Flash書(63)
教程(73)
Design Patterns(3)
FlashCom筆記(47)
Flash Remoting筆記(27)
Flex筆記(11)
Flash Lite筆記(14)
PHP資訊(23)
Ajax筆記(9)
習作(51)
組件(17)
酷站(32)
學習資源(28)
書籍推介(15)
本站與我(91)
RSS瀏覽器
聯絡
熱愛鑽研
Ajax
ActionScript
Flash
Flash Lite
Flex
Flash Remoting
FlashCom
Director
Lingo
PHP
Multiplayer Game

搜尋
VCASMO
AMFPHP不兼容PHP 5.0.3 (16-02-2005)

今天我發現的問題,PHP 5.0.3裡,所有從Flash送到AMFPHP的參數,如果Data Type不是Number,例如是String,都會產生NetConnection.Call.BadVersion問題。經過求證後,是PHP5更改了pass-by-reference/pass-by-value做法,AMFPHP開發社群已經有解決提案,所以目前我建議如需要使用AMFPHP,還是在PHP4裡進行比較好。

可惜我自己的新Server正是跑PHP 5.0.3 T_T

本文章由發表。
意見
  • pass-by-refrence英文字拼錯了...
    pass-by-reference

    由路人乙於16-02-2005發表

  • 不知道 Luar 兄是否使用或了解过PHPObject [ http://ghostwire.com/go/28 ]

    不知 AMFPHP 和 PHPObject 相比较起来你更看好那个?!

    由Mimosa於25-02-2005發表

同組文章

Movable Type 4.32-en系統支持,Luar's Production版權所有。